Back to overview
Resolved
Authentication & Payment system updates
Aug 5, 2026 at 11:30pm UTC
–
Aug 6, 2026 at 2:30am UTC
Affected services
ChimeEdu App (app.chimeedu.com)
Resolved
Aug 6, 2026 at 2:30am UTC
Maintenance ended
Affected services
Created
Aug 5, 2026 at 11:30pm UTC
The authentication systems & payment systems for the platform are currently undergoing planned maintenance, as part of scheduled security and feature updates. Users may be logged out of their accounts unexpectedly during this time.
Affected services